
Tutorial: Creating a Departmental Website in FrontPage 2003 
 
This tutorial introduces you to some of the functions of Microsoft FrontPage 2003.  In this 
tutorial, you will create the shell of a basic website.  You may be able to use this site as a 
template for your own departmental site, or you may want to create your own site from scratch 
once you have learned these basic techniques. 

 

 Create a New Website 
1. Open FrontPage 2003.   

2. Create an empty web by selecting File > New. (A panel will open on the right.) Select 
One page Web site…  

3. In the open dialog box, select Empty Web Site. Click Browse and navigate to My 
Documents. Click on the new folder icon and give it a name. 

4. Click OK. 

 

This just saved your new website to your laptop. It is important to have a unique name for your 
site.  (Note: when you publish your own website, this name will not necessarily be carried over.) 

 

 Create the Homepage 

The filename for the home page will be index.htm, so that it will automatically load if the name of 
the web is entered in a browser.  Included in the homepage is: 

 global links for all areas of the site 

 header, footer, other graphics 

 contact information 

 
1. Select View to ensure that the Folders view is selected. 

2. Select File > New > Blank Page.  

 
Header >> 
3. Add a banner which has already been created and saved in your new web folder in the 

Images folder. (The banner should be a JPEG graphic.)  Select Insert > Picture > From 
File.   

4. Center the banner by selecting it and choosing the centering icon from the formatting 
toolbar. 
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Global links >> 
5. Place the cursor below the banner and select Table > Insert > Table. 

6. In the dialog box, enter 2 rows and 2 columns, make the border size 0, and click OK. 

7. An outline of the table appears.  Make left-hand column narrow (just wide enough for the 
links) and the right column should encompass most of the window by dragging the 
center vertical line to the left.   

 
Homepage title >> 
8. Select File > Properties > General Tab.   

9. In the Title text box, enter the desired title of your page. This will appear on the top bar of 
the browser. 

10. Save the page.  

 

 

 Add Pages to the Website 

When you create a new page, you need to give it an appropriate filename and a page title, 
which will appear in the title bar in the user’s browser. In this part of the exercise, we’ll 
create the files in Folder View, and give them both filenames and page titles. 

 

Create the new pages >> 
1. Select View > Folders.   

2. Select File > New. 

3. A panel opens on the right side of the screen. Select Blank Page. A new page called 
new_page_1.htm opens. 

4. To change its name, select File > Save As.  

5. Type the desired name and click Save. 

6. Select File > Properties and change the Title. 

7. Create new pages using the same procedure for the other sections of your site.  
 
Set up navigation >> 
This is useful mainly to have FrontPage generate navigation bars automatically. You may 
not always want to do this but we’ll set it up in case we want to use this FrontPage 
capability.  It is also helpful to visualize the structure of the site. You must have all of your 
pages created first in order to use this function. 

1. Select View > Navigation. A graphical representation of the index page appears. 

2. Place the five section pages you just created on the next level under the index page in 
the graphical representation.  You can do this one at a time, or all at once.   
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a. Right-click on the index page and select Add Existing Page… 

b. Repeat this last step for the other pages. 

 
 Add Content 
1. Select View > Folder. 
2. Double-click on one of your pages.  This will switch you to Page view automatically, and 

you will be looking at the blank page. 

3. To turn the shared border option on, select Tools > Page Options. Shared borders 
create a header and footer that are consistent across all of the pages in your site. 

4. Click on the Authoring tab and click the checkbox next to Shared Borders. Click OK. 

5. Select Format  > Shared Borders. 

6. Select the All Pages radio button. 

7. Click on the checkboxes next to: 

- Top & Include navigation buttons 
- Bottom 

8. Click OK.   

9. To add the banner, click above the dotted line and press Enter to create a blank line 
above the page title.   

10. With you cursor on the new blank line, select Insert > Picture > From File.  

11. Browse to the banner and click the Insert button. 

 

Make sure that the links are correct >> 
12. Right-click on one of the links and select Link Bar Properties from the menu.   

This states that every page will have links on it to other pages on the same level, which 
includes the “parent” page, one level up, and the main home page.  In this case, we should 
have all of the pages link to the main page for each section, including the home page. 

13. Select Child pages under home and click OK.  Note that nothing changes on this page, 
but when we have pages at lower levels, it will ensure that the main section pages are 
accessible from those pages as well.   

14. To open up one of the other pages and see how it looks, double-click on a different 
page. Notice that it looks about the same.  

 
Add Content from a Word File >> 
1. Open one of your pages and click the cursor between the gray dotted lines (within the 

body). 

2. You can insert content from a word document if desired. To do so, select Insert > File 
and locate the file. (You may have to change the Files of type to ‘All Files’) 
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3. Click Open. 

4. Click the save button on the tool bar.  

The text from the Word file is inserted into the page.  Note that formatting is preserved,   
translated automatically into HTML. 

 

Reformat index page >> 
5. Select the index.htm tab to view that page.   

Now on the index page there are two banners. To remove the top shared border and create 
the links along the left side on the index page only:    

6. Select Format > Shared Borders.   

7. Under Apply to: select the Current Page radio button, and uncheck Top.   

8. Click OK.  (The border should be gone on the index page only.) 

 
Add a vertical link bar >> 
9. Click in the upper left-hand cell of the table.   

10. Select Insert > Web Component.   
11. Select Link Bars on the left and Bar based on Navigation Structure on the right.   

12. Click Next. 
13. Select a bar style (preferably the same one...and simple) for your link bar and click Next.  
14. Select the vertical orientation and click Finish. 

15. On the Link Bar Property dialog box, select Child pages under home and check 
Home page on the right.   

16. Click OK. 

 
Preview your page >> 
1. Select File > Save All to save your pages before previewing in the browser. 

2. Select File > Preview in Browser > Microsoft Internet Explorer 6.0. You can click on 
the links to navigate among the pages.   

 
Add Image to Page >> 
You can insert images and add a rollover behavior to the image.  

1. Click in the upper right cell of the table on the home page. 

2. To insert the main picture, select Insert > Picture > From File.  

3. Find the file and click Insert. This image should already be created and saved into the 
Images folder of your designated web folder that was set up at the beginning of this 
tutorial. 
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4. Click on the right-align icon on the formatting toolbar.   

5. Place the cursor on the right edge of the table and drag the edge of the table in until the 
table is slightly narrower than the banner above it. 

 
 
Center the table >> 
Next, center the table on the page. Also change the table so it’s measured in pixels rather 
than as a percentage of the window.  That way, the size will be more stable on the users’ 
screen instead of varying based on the width of their browser window.  It will still vary some 
based on the resolution of their monitor. 

1. Select the entire table (The easiest way is to double-click in the margin to the left of the 
table).   

2. Right-click on the table and select Table Properties.   

3. In the Alignment drop-down box, select Center. 
4. Where it says Specify width, select the In pixels radio button and type “600”.  Note: if 

the information in the table is wider than 600 pixels, it will still show the whole thing. 

 
(Note: pixels were used so that the size will be more stable on the user’s screen instead of 
varying based on the width of the browser window.) 

 
 
Add the rollover >> 
5. Select the inserted picture. 

6. Select Format > Behaviors.   

7. In the panel that appears on the right, click Insert > Swap Image.  

8. In the box select the rollover image. This should be the same image with a variation to it, 
or some image that is the same size to swap with the original one. 

9. Click Browse and navigate to the desired image. 

10. Click the check box next to Restore on mouseout event.  
11. Click OK.  

12. Save all of your pages and preview them in the browser (File > Preview in Browser) to 
see the rollover effect. 
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Add contact information >> 
The information will go below the linkbar and picture, in the bottom shared border (footer). 

1. Click inside the shared footer (below the dotted line) and select Insert > Horizonal Line 
to set the bottom border off from the rest of the page. 

2. Type the contact information as you want it to appear.  To put in a line break to return to 
the next line (instead of a full paragraph break, hit Shift-Enter). 

 

 

Add a link to Ursinus home page >> 
1. Place the cursor inside the bottom shared border and insert an Ursinus Logo. 

2. Select the logo and right-click on it. Select Hyperlink from the menu or hit the hyperlink 
icon in the toolbar. 

 

 

 

 

 

 

3. In the Insert Hyperlink dialog box, type in “http://www.ursinus.edu” for the address. 

4. Click on the Target Frame… button, and select New Window.  (This makes the site 
appear in a separate window) 

5. Click OK.   
6. Click the Style… button and select Format > Border (this is referring to the border of 

around the graphic)  

7. Choose outset from the border styles.  (This will put a slight edge around the logo so it 
is obvious that it is a clickable link.) 

8. Click OK three times. 

 

Add a last modified date >> 
It is nice for visitors to know is how current your pages are. To do so: 

1. Place the cursor after the Ursinus icon and press Enter.   
2. Type “This page last modified:” 

3. Select Insert > Date and Time 

4. Make sure the Date this page was last edited radio button is selected. 

5. Select your preferred Date format from the drop-down box and click OK. 

 

- OR -
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Note: The link back to the Ursinus home page and the modification date should appear in 
the shared border on the bottom of each page of your website.  Since the modification date 
is dynamic data, it may be different for each page as you edit and publish individual pages. 

 

 Add supporting page and organization 

To add pages that are exist as a sub-page off of one of the main pages: 

 

Add a new folder and blank page >> 
1. In Folder view, right-click on the top level folder and select New > Folder. 
2. Name the new folder.  (Note: lowercase works best for web pages and folders.) 

3. Right-click on the courses folder and select New > Blank Page. 

4. Right-click on the page, select Rename, and give it a name. 

5. With the page selected, go to File > Properties and give it a title. 

6. Double-click on the page to open it in Page view. 

 

Add the page to the navigation structure >> 
1. Change to Navigation view. 

2. Drag the icon for your new page from the Folder list to the blue area, underneath the 
page it exists under. 

3. Open the page and right-click on the linkbar and select Link Bar Properties to 
accurately set up the links. 

4. Select Child pages under Home (the main section pages), and make sure Home page 
and Parent page are checked.   

5. Click OK. 

 

 

Add links to other pages >> 
1. Double-click on a page in the Folder list to open it. 

2. In the body of the website (between the shared borders), type some text that will be 
turned into a hyperlink. 

3. Highlight the text of the link.   
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4. Right-click on this text and select Hyperlink from the menu or hit the hyperlink icon in 
the toolbar. 

 

 

 

 

 

 

5. Click in the Address field and type in the desired web address.  

6. Click on the Target frame… button and select New Window.   

7. Click OK twice. 

 

Note: Even after we publish the site, it is not linked to from any other sites on the 
Internet, so unless you are specifically told about it, a user cannot surf onto the 
page.  Thus, search engines will not be able to find it until it’s linked to from other 
sites. Visitors must know the exact URL in order to get to it. 

 

Publish your website >> 
Currently, your website is only visible in the browser from your own computer.  In order to 
make it accessible, you must publish it on a web server. If publishing a personal website, 
follow the following directions. If publishing a departmental website, contact Paula Laholt ( 
x2678) or Stacey Gawrys (x2755) to set up your web space. 

1. Select File > Save All to save your files.  Then select File > Publish Site. 

2. Select the FTP radio button under Remote Web server type. 

3. For the Remote Web site location, type “ftp://webpages.ursinus.edu”  

4. Click OK. 

5. A dialog box will open. Enter your user name (“ursinus\username”) and password. 

6. Click OK. 

7. In the bottom right corner, click the Publish Web site button. 

8. When it is finished, you can view your website online in the browser at: 
”http://webpages.ursinus.edu/username” 

 

- OR -


